
 

Guided Tour



             
Reference Manager®

Demo Version 11, for Windows

COPYRIGHT
 2004 Thomson ISI ResearchSoft, all rights reserved worldwide. No part of this publication 
may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into 
any language in any form by any means, without written permission from Thomson ISI or 
Thomson ISI ResearchSoft.

TRADEMARKS
Reference Manager is a registered trademark of Thomson. Cite While You Write is a 
trademark of Thomson. Microsoft and Windows are registered trademarks of Microsoft 
Corporation. All other product and service names cited in this manual may be trademarks or 
service marks of their respective companies. 

NOTICE REGARDING LEGAL USE OF DOWNLOADED REFERENCE DATA
Reference Manager gives you the capability to import references from online databases and 
store them in your personal Reference Manager databases. Some producers of online 
reference databases expressly prohibit such use and storage of their data; others charge an 
extra fee for a license to use the data in this way. Before you download references from a database, 
be sure to carefully check the copyright and fair use notices for the database. Note that different 
databases from the same provider may have varying restrictions.
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Reference Manager® End User License Agreement

BACKGROUND. ISI ResearchSoft, a division of Institute for Scientific Information, Inc., has 
developed a proprietary computer program designated “REFERENCE MANAGER” (the 
“Software”). You (the “End User”) may use the Software to create personal bibliographic 
databases and to search those databases. By using the Software and/or its accompanying 
manuals (the “Documentation” and together with the Software, the “Product”), you agree 
with ISI ResearchSoft to be bound by the terms and conditions set forth herein. ISI 
ResearchSoft is willing to permit you to use the Product only upon the condition that you accept 
and comply with all of the terms of this agreement (“Agreement”).

THEREFORE, for good and valuable consideration, including the rights and license granted in this 
Agreement, and intending to be legally bound, ISI ResearchSoft and End User agree as follows:

1. LICENSE. ISI ResearchSoft hereby grants to End User a non-exclusive, non-transferable, 
individual license to use the Product solely for testing and evaluation purposes, subject to 
the terms and conditions of this Agreement. End User understands that the Software will 
not permit End User to access any given database for more than 20 sessions. End User may 
not make any copies of the Documentation or any portion thereof. 

2. RESTRICTIONS. End User may not modify, translate, decompile or reverse engineer the 
Product, or any portion thereof, without the prior written consent of ISI ResearchSoft. 
Except as expressly set forth in this Agreement, End User may not make any use of the 
Product.

3. TERMINATION. Without prejudice to any other rights, ISI ResearchSoft may terminate 
the license granted hereunder if End User fails to comply with any of the terms and 
conditions of this Agreement. In such event, End User shall immediately discontinue any 
further use of the Product and destroy all copies of the Software and Documentation in its 
possession or control. 

4. PROPRIETARY RIGHTS OF ISI RESEARCHSOFT. End User agrees that ISI 
ResearchSoft is the sole and exclusive owner of all rights in the Product. The Product is 
protected by United States copyright and other laws, as well as international treaty 
provisions, and End User must treat the Product as any other copyrighted and legally 
protected material. All rights in the Product not expressly granted herein are reserved by 
ISI ResearchSoft. 

5. NO WARRANTY. THE PRODUCT AND ALL CONTENT AND INFORMATION CONTAINED THEREIN 
ARE BEING PROVIDED TO YOU "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS 
OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE WITH RESPECT TO THE 
PRODUCT OR THE USE THEREOF. ISI RESEARCHSOFT DOES NOT MAKE ANY WARRANTY THAT 
THE SOFTWARE IS COMPATIBLE OR OPERABLE WITH THE END USER'S COMPUTER EQUIPMENT 
OR SOFTWARE, OR THAT THE SOFTWARE WILL PERFORM WITHOUT INTERRUPTION OR FREE 
OF ERRORS. END USER AGREES THAT THE PRODUCT IS NOT CONSUMER GOODS FOR 
PURPOSES OF FEDERAL OR STATE WARRANTY LAWS.

No salesperson or other representative involved in the licensing of the Product is 
authorized to make any warranties with respect to the Product. Oral statements do not 
constitute warranties, shall not be relied upon by End User, and are not a part of this 
Agreement.
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6. LIMITATION OF LIABILITY . TO THE MAXIMUM EXTENT PERMITTED BY LAW, IN NO 
EVENT SHALL ISI RESEARCHSOFT OR ITS AFFILIATES OR ITS OR THEIR RESPECTIVE 
DIRECTORS, OFFICERS, EMPLOYEES, AGENTS OR REPRESENTATIVES (COLLECTIVELY "ISI 
PARTIES") BE LIABLE OR RESPONSIBLE FOR DAMAGES OF ANY KIND (INCLUDING, WITHOUT 
LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS 
OF INFORMATION OR DATA, OR ANY OTHER INDIRECT, INCIDENTAL, SPECIAL OR 
CONSEQUENTIAL DAMAGES) ARISING OUT OF THE USE OF OR INABILITY TO USE THE 
PRODUCT OR OTHERWISE IN CONNECTION WITH THIS AGREEMENT, EVEN IF ISI 
RESEARCHSOFT HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN ANY 
EVENT, THE ISI PARTIES’ TOTAL AGGREGATE LIABILITY TO YOU FOR ALL DAMAGES OF 
EVERY KIND AND TYPE (REGARDLESS OF WHETHER BASED IN CONTRACT OR TORT) SHALL 
NOT EXCEED THE PURCHASE PRICE OF THE PRODUCT. 

IT IS EXPRESSLY UNDERSTOOD AND AGREED THAT IN THE EVENT ANY REMEDY HEREUNDER 
IS DETERMINED TO HAVE FAILED OF ITS ESSENTIAL PURPOSE, ALL LIMITATIONS OF 
LIABILITY AND EXCLUSIONS OF DAMAGES SET FORTH HEREIN SHALL REMAIN IN EFFECT.

7. INJUNCTIVE RELIEF. End User agrees that ISI ResearchSoft will have the right to 
obtain an injunction against any unauthorized use of the Product by End User, in addition 
to any other rights and remedies to which ISI ResearchSoft may be entitled.

8. SEVERABILITY. If any provision of this Agreement is held to be invalid or 
unenforceable by a court of competent jurisdiction, then such provision shall be adjusted 
to the minimum extent necessary for validity or enforceability, and in any event, the 
remaining provisions will nevertheless remain in full force and effect.

9. ENTIRE AGREEMENT. This Agreement constitutes the entire understanding and 
agreement between ISI ResearchSoft and you with respect to the subject matter of this 
Agreement and supercedes all prior or contemporaneous, oral or written communications 
with respect thereto. This Agreement may not be modified, except to the extent of a 
written agreement to do so by an authorized representative of ISI ResearchSoft.

10. CHOICE OF LAW.   This Agreement shall be interpreted, construed and enforced in all 
respects in accordance with the internal laws of the State of Pennsylvania, without 
regard to its principles of conflicts of law.

11. ACKNOWLEDGMENT. Use of the Product affirms that End User has read this 
Agreement, understands it, and agrees to be bound by its contents.
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Introduction: Welcome to Reference Manager

Introducing Reference Manager
Welcome to Reference Manager—your connection to all things 
reference related! 

� Reference Manager is an online search tool—it provides a 
simple way to search online bibliographic databases and 
retrieve the references directly into Reference Manager. 
(Reference Manager can also import data files saved from a 
variety of online services, CD-ROMs, and library databases.)

� Reference Manager is a reference database—it specializes in 
storing, managing, and searching for bibliographic 
references in your personal reference database. 

� Reference Manager is a Web Publisher—it includes a Web 
publishing tool and built-in Web server so you can post up 
to 15 databases to the Web or an intranet in seconds.

� Reference Manager is a bibliography maker—it formats 
citations in Microsoft® Word with the Cite While You 
Write™ feature and in WordPerfect with the Reference 
Manager Add-in feature. Watch the reference list grow as 
you insert citations in your manuscript. 

See “What’s New in Reference Manager 11” on page 10 for a list 
of the most recent features added to Reference Manager. 

About This 
Demo Version 
of Reference 
Manager 

This is a demonstration version of Reference Manager 11. You 
can use the program to open a database 20 times in order to 
evaluate Reference Manager and all of its features. After those 20 
sessions are up, the Demo version will no longer operate.

To purchase an unrestricted version of the Reference Manager 
program, please contact Thomson ISI ResearchSoft.

About the 
Guided Tour

This guide provides a basic overview of installing and using 
Reference Manager. It assumes that you know how to use your 
Windows operating system and your word processor. For help 
on these topics, consult your computer owner’s guide or your 
word processor manual. 

Throughout this guide, menu names, menu items, and button 
names appear in italic text.
Introduction: Welcome to Reference Manager 7



                                                           
The following representations for key combinations are used:

Instruction Explanation

CTRL+ESC While holding down the CTRL key, press 
the ESC key. 

CTRL+ALT+ENTER While holding down the CTRL and ALT 
keys, press the ENTER key.

Customer Services

Online Help For additional information about using Reference Manager, 
consult the online Help file. 

From Reference Manager’s Help menu, select Help Topics to view 
the various topics. 

Customer 
Service

Contact Sales for general product information, pricing, quantity 
discounts and referrals to dealers. Contact Customer Service for 
orders and billing/shipping status. 

Sales Information
Mail: Thomson ISI ResearchSoft

2141 Palomar Airport Road, Suite 350
Carlsbad, CA 92009 U.S.A.

Phone: (760) 438-5526 (country code is 01)
Fax: (760) 438-5573 (country code is 01) 
Web: http://www.refman.com
Email: www.refman.com/rmcontact.asp

Customer Service (Orders, Billing, and Shipping)
Mail: Thomson ISI ResearchSoft

3501 Market Street
Philadelphia, PA 19104 U.S.A.

Phone: (800) 336-4474 (country code is 01)
Fax: (215) 386-2911 (country code is 01) 
Web: http://www.refman.com
Email: www.refman.com/rmcontact.asp
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Technical 
Support

Contact Technical Support if you encounter problems while 
using Reference Manager. Before contacting us, have a clear 
description of the problem and know the version of your 
operating system, Reference Manager, and your word processor. 
(To find the Reference Manager version, start Reference Manager 
and choose About Reference Manager from the Help menu.) 

Our hours are Monday–Friday, 8:00 am – 5:00 pm Pacific Time.

Mail: Thomson ISI ResearchSoft
800 Jones Street
Berkeley, CA 94710 U.S.A.

Phone: (408) 987-5609 (country code is 01)
Fax: (510) 559-8683 (country code is 01) 
Web: http://www.refman.com
Email: www.refman.com/rmcontact.asp

Technical support tips are also available on the Reference 
Manager Web site and through the ris-interest email forum (see 
below).

International 
Customer and 
Technical 
Support

For customer support or technical support outside of North 
America, please visit our Web site to check for a local distributor. 

Go to http://www.refman.com, click on Contact Us, and then 
click on International Distributors to find a local distributor. 

The Reference 
Manager-
Interest 
Email Forum

If you wish to join an ongoing email forum of Reference Manager 
users like yourself, go to the Reference Manager Web site at 
www.refman.com, click on Support and Services and then scroll 
down for instructions on how to subscribe to the Reference 
Manager Interest List. 

In general, Thomson ISI ResearchSoft does not answer questions 
posted to ris-interest, but lets users answer each other’s 
questions. Contact ISI ResearchSoft directly for a guaranteed 
response from technical support staff.
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What’s New in Reference Manager 11

New Database Features
� Share reference databases with colleagues over a network 

and through your own Reference Manager Web Publisher 
intranet or Internet site.

� Import or Export a reference list in XML format.

Bibliography Tools
� Create a subject bibliography with topic headings for easily 

producing curricula vitae and reading lists. 

Cite While You Write
� Export a traveling library from a Microsoft Word document 

into a Reference Manager database—share references cited 
by colleagues. 

� Highlight text in a document and use Insert Citation to find 
and insert references for citing instantly.

� Preview and edit in-text citations throughout an entire 
document.

� Navigate easily between your manuscript and Reference 
Manager database.

Connectivity
� Connect to more online resources and create bibliographies 

in over 900 styles.

� Locate full text faster by connecting to your institution’s 
online resources with OpenURL Record links.

� Move references between Reference Manager and RefViz™ 
in one step—explore your reference collection visually.
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Chapter 1: Reference Manager Installation

Requirements 
The Reference Manager Demo is available on CD or by 
downloading. If you have the CD you need a CD-ROM drive to 
install the program.

System 
Requirements

Reference Manager runs under the following operating systems: 

� Windows 2000

� Windows XP

Hardware 
Requirements

Hardware Requirements:

� A 133 MHz or higher Pentium-class CPU

� A minimum of 128 MB of available RAM

� A hard drive with at least 90.5 MB of free space

� In order to use Reference Manager’s Internet Search 
command or to use the Web Publisher component, an 
Internet connection is required. To use the Open Link 
command to access a Web site, you also need a Web browser 
installed.

Word 
Processor 
Compatibility

As of March 2004, Reference Manager for Windows is 
compatible with: 

� Microsoft Word for Windows 2000/XP (2002)/2003

� WordPerfect for Windows 9 (2000), 10 (2002)and 11 (2003)

Microsoft Word uses Cite While You Write, and WordPerfect 
uses the Reference Manager Add-in. These functions put a 
Reference Manager submenu of commands on Word or 
WordPerfect’s Tools menu. They also allow Reference Manager 
to format citations and create a bibliography for the document 
that is open in Word or WordPerfect. You can format, unformat, 
and reformat a single document—without ever exiting your 
word processor.

If a supported version of Microsoft Word or WordPerfect is 
installed on your computer, the appropriate Cite While You 
Write or Add-in files are automatically installed for the current 
user account when you run the Reference Manager installation 
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from the current user account. These features can be used with a 
shared copy of Word or WordPerfect on a network. 

In order for Cite While You Write or the Add-in to install 
properly:

� Microsoft Word or WordPerfect must be correctly installed 
on your computer prior to installing Reference Manager.

� During the Reference Manager installation process, your 
account will need administrative rights to the local machine.

� For Word, the Reference Manager installer must be able to 
locate the Word Startup folder. You need to have full read 
and write access to Word’s Startup folder in order to install 
Reference Manager commands.

Installing Reference Manager

Installing the 
Demo Version

To install Reference Manager:

1. Log in to the local machine with administration rights, and 
make sure no applications are running. 

NOTE: Make sure you are not running any anti-virus software during 
the installation process.

2. Insert the Reference Manager Demo CD into your CD-ROM 
drive.

3. The Reference Manager Setup program will start. If you do 
not have Autoplay enabled, choose Run from the Start menu, 
type “d:\setup” (use the drive letter appropriate to the drive 
containing the installation CD) and press ENTER.

4. Follow the instructions on the screen to complete the 
installation.

� By default, Reference Manager is installed in the 
C:\Program Files\Reference Manager 11 folder. You can 
change this folder if you wish. 

� Reference Manager can be installed to allow only you, or 
anyone using the computer, access to the application 
shortcuts on the Start menu. By default, the option to 
allow anyone using the computer access to the shortcuts 
is selected.

� Read the “Readme” file for any last minute information 
that may not have made it into the manual.
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Checking Your Installation
To run the Demo version of Reference Manager 11, click the Start 
button, choose All Programs or Program Files, select Reference 
Manager 11, and then choose Reference Manager 11. To check the 
version number of Reference Manager, choose About Reference 
Manager from the Help menu. 

If you have trouble accessing the program, repeat the installation 
steps to verify that the program was correctly installed.

Checking 
Microsoft 
Word Support

To see if Cite While You Write is correctly installed, start Word 
and click on Word’s Tools menu. In Word 2000, XP, or 2003, you 
should see Reference Manager commands on a Reference Manager 
11 submenu. 

Word 2000, XP, or 2003 Tools menu and Reference Manager 11 
submenu 
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Checking 
WordPerfect 
Support 

To see if the Reference Manager Add-in is correctly installed, 
start WordPerfect and click on the Tools menu. You should see a 
Reference Manager 11 submenu with various Reference Manager 
commands.

WordPerfect Tools menu and Reference Manager 11 submenu
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Installing Word Processor Support Later
When you install Reference Manager, the installer program looks 
for Microsoft Word and WordPerfect on your computer. If it 
finds a compatible version, the appropriate Cite While You Write 
word processor files are installed for the current Windows user 
account. There are several instances, though, where you may 
need to reinstall these files after Reference Manager is installed:

� You did not install Reference Manager from your user 
account.

� When you installed Reference Manager, you did not have 
full read and write access rights for your account.

� You installed or upgraded your word processor after 
installing Reference Manager.

To install word processor support:

1. Log in to your Windows user account with full read and 
write access rights.

2. Use Windows Explorer to navigate to the Program 
Files\Reference Manager 11 folder.

3. Double click on the RefManConfig.exe file.

4. On the dialog, select the word processor files you wish to 
install (Cite While You Write for Word or the Add-in for 
WordPerfect) and click Next.
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Uninstalling Reference Manager
Uninstall the Reference Manager demo program by using the 
“Add/Remove Programs” function in the Windows Control 
Panel.

To uninstall the Reference Manager 11 Demo program:

1. Make sure Web Publisher is disabled.

a. From the Tools menu in Reference Manager, select Web 
Publisher.

b. Click on the Configure tab.

c. Select the button to “Disable Web Publisher.”

d. Click OK.

e. Exit Reference Manager

2. From the Windows Start menu, select Control Panel, or 
choose Settings and then Control Panel.

3. Select Add or Remove Programs.

4. Select the Reference Manager 11 program.

5. Click the Remove button.

The Uninstall program removes only files, groups, and icons 
installed by the Reference Manager installer the last time it was 
run.

It will not delete your databases or any new files you have 
created. It will not delete folders if they contain files you created. 
You will need to manually delete those files with Windows 
Explorer.
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Chapter 2: Introducing the Guided Tour

This Guided Tour walks you through a series of exercises to get 
to know the basics of Reference Manager. It is best if you take the 
tour one step at a time. 

Tour 
Objectives

After completing the exercises in this Guided Tour you should 
be able to:

� Understand the major uses of Reference Manager as a 
bibliographic database program

� Easily navigate references in a database with commonly 
used features

� Build a database by importing references and entering 
references manually

� Search a Reference Manager database

� Use term lists for easy global editing and creating synonyms

� Build bibliographies in Microsoft Word or WordPerfect

� Print bibliographies and subject bibliographies directly from 
Reference Manager

� Post Reference Manager databases on a personal Web server

Using the 
Sample 
Database with 
the Exercises

The exercises in this Guided Tour use the Sample database that 
is automatically installed when you install Reference Manager. 
You will use the Sample database to learn how to navigate a 
database, enter references, search a database, and build 
bibliographies. When you are done with the Guided Tour, you 
can experiment further with the Sample database.

NOTE: Remember that the Reference Manager 11 Demo version is 
active for 20 sessions; after you open a database 20 times, the program 
will no longer operate.

Database 
Capacity

Depending on your system’s resources, you can create an 
unlimited number of Reference Manager databases, each with an 
unlimited number of references. In Reference Manager, all text 
fields are variable length and can include almost any type of 
information. The manner in which information is entered is 
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directly related to producing correctly-formatted in-text 
citations and bibliographies.

Reference 
Types

It is possible to have many different reference types in a 
Reference Manager database. For example, you can store 
Audiovisual Material with Journal Article and Book references. 
Reference Manager comes with 35 predefined reference types for 
you to select when entering references.

While Reference Manager is designed and used for bibliographic 
references, you can use the program to store records of any type. 
You can use any of the predefined reference types or you can 
modify them to create a custom reference type. Each reference 
type can include up to a maximum of 37 fields.

Online Help When using Reference Manager, many of your questions can be 
addressed using the online help that comes with the program. 
There are several ways you can access online help when using 
Reference Manager:

� From the Help menu, choose Help Topics to find a topic using 
the Contents, Index, or Find tab.

� In many Reference Manager windows, click the Help button 
to see information related to the current activity.

� Press the F1 key to display context-sensitive help. 
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Chapter 3: Navigating a Database

In this section of the Guided Tour you will learn to:

� Open an Existing Database

� Customize the Reference List

� Customize the Database Sort Order

� Click Sort on Column Headings

� Drag and Drop between Databases

Exercise – 
Opening the 
Sample 
Database

To open the Sample database:

1. From the Windows Start menu, locate the Reference Manager 
11 program group and choose Reference Manager 11.

If you have previously used Reference Manager, the last 
Reference Manager database used may automatically open. 
Check the database tab at the bottom of the screen to be sure 
the Sample database is open. If it is not, close the current 
database by going to the File menu and choosing Close 
Database. 

From the File menu, choose Open Database to continue. The 
Open Reference Manager Database dialog appears.
Chapter 3: Navigating a Database 19



2. In the Open Database dialog:

a) In the “Look in” box, navigate to the Reference Manager 
11 folder. The default location is C:\Program 
Files\Reference Manager 11.

b) At the bottom of the dialog, in the “Access rights” box, 
select Read-Write Exclusive. 

NOTE: By default, databases are opened with Read-Write Share 
access rights. However, to make any global changes to a database, you 
must open it with Read-Write Exclusive access rights.

c) In the Reference Manager 11 folder, locate the Sample 
database (Sample.rmd) and either double-click on it or 
highlight it and click Open.

Notice that the Sample Database window has two panes: the top 
pane is the Reference Display, and the bottom pane is the 
Reference List.

The Reference Display, the top pane in the Database window, 
details the reference highlighted in the Reference List. You can 
edit the highlighted reference in the Reference Display. 

The default Reference List shows the Reference ID, Author, and 
Title fields. (Later, you will learn how to customize this view to 
include any field.) The Reference List provides a way to browse 
through single-line references, mark or unmark references, or 
display records in full for viewing or editing.

Next, take a closer look at how to navigate the Reference List.
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Exercise – 
Customizing 
the Reference 
List

While the default Reference List shows three Reference Manager 
fields (Reference ID, Author, and Title), the list can be 
customized to display as many fields as you would like.

In the following exercise you will customize the Reference List 
by selecting different fields to display and then changing the 
column widths.

To select the fields to display:

1. From the Tools menu, choose Reference List Display. 

Each column represents a field appearing on the Reference 
List.

� Field Order—The first row allows you to specify the 
order in which the fields appear.

� Header—The second row allows you to modify the text 
appearing as a Header.

� Field Type—Row three allows you to select the field you 
want to view.

2. Move the mouse pointer over column 3 of the Field Order 
row. When the cursor changes to a downward arrow, click 
the mouse to highlight the entire third column.

3. Click the Insert Col button.

A new column is inserted before the third column; the 
original third column moves to the right. The newly inserted 
column defaults to Ref ID as the Header and Field Type.

4. Click the Field Type row in the new column and select “Date, 
primary” from the drop-down list that appears. The list is 
alphabetized, so you will need to scroll up to find “Date, 
primary.”

The Header row automatically changes when you select a 
new Field Type.
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5. Click the Header row in the new column and change “Date, 
primary” to “Date” by deleting the word primary.

6. Click OK to save your changes. Reference Manager displays 
a message asking whether you would like to copy this 
reference list format to all reference lists. Click Yes. The Date 
field now appears in the Reference List.

You can resize the width of the columns easily by dragging 
between column titles. Use the next exercise to change the width 
of the Date field in the Reference List.

Exercise – 
Changing the 
Column Width

You can adjust the width of the Date column to allow more room 
for the Title column.

To adjust column widths:

1. In the Reference List, place the cursor on the vertical line 
separating the Date and Title column headers.

The cursor changes to a left/right directional icon allowing 
you to reset the width.

2. Drag the vertical bar to the left to reduce the width of the 
Date field.

3. Experiment with changing other column widths.

Exercise – 
Customizing 
the Database 
Sort Order

Several sorting options are available in Reference Manager. You 
can specify a custom database sort order to be applied anytime a 
Reference List appears, as well as a separate sort order applied 
to search results. You can also perform instant sorts using the 
column headers in the Reference List.
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To change the database sort order:

1. To change the database sort order for an existing database, 
go to the Tools menu and choose Change Database Sort Order.

2. In the Database to Change box, make sure the Sample 
database is selected. 

NOTE: If the Sample database does not appear as an option in the 
Database to Change box, you did not open the database with Read-
Write Exclusive access.

Author is already set up in the primary Sort By box. You will 
set up a secondary sort order for Title and Date fields.

3. Click the drop-down list in the first Then By box (the second 
level of the sort) and change the field to “Title, primary.” 
Select Ascending order.

4. Click the drop-down list in the second Then By box (the third 
level of the sort) and change the field to “Date, primary.” 
Select Descending order.

5. Click the Sort button.

Reference Manager displays the message “Resort 
successfully completed” when the sort is complete.

6. Click OK to close the dialog box, and then click Close to see 
the results of your settings.

You can also set up the database sort order when you create a 
new database. To see how this works, from the File menu, choose 
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New Database and then click the Advanced button. Click Cancel to 
leave without making changes.

Exercise – 
Changing the 
Sort Order 
Instantly

Instant sorts can be performed on any column header in the 
Reference List when you want to adjust the sort order without 
making permanent modifications. 

To use the click sort method to sort by a displayed field:

1. To sort by the Date field, click the Date column header. The 
references are sorted by date in ascending order. Click a 
second time to change the sort order to descending.

2. Experiment with sorting the references by another column 
header such as Author and locate the name “Marten, Ken.” 
Use the scroll bar to the right of the Reference List; notice the 
scroll tip that appears to show you your location in the list.

Exercise – 
Copying or 
Moving 
References 
from One 
Database to 
Another

Reference Manager makes it easy to copy or move references 
between databases. To copy or move references, you need to 
have two databases open. For this exercise, we will first create a 
new empty database.

To create a new database and then copy references:

1. From the File menu, choose New Database. 

2. On the file dialog, enter a new name for the database – type 
“Test” for this exercise – and click New.

You should have two Reference Manager databases open 
now, Test and Sample. Notice the two tabs with the database 
names at the bottom of the window.

3. Click the Sample database tab, and highlight a reference in 
the Reference List.

You can highlight multiple references by using CTRL-CLICK 
to select non-contiguous references or SHIFT-CLICK to select a 
range of references. Once you highlight more than one 
reference, the top Reference Display goes blank, as it can 
only show a single reference.

4. To copy the highlighted reference(s), hold down the CTRL 
key, drag them to the Test database tab, and release the 
mouse.

(To move references, you would use the same process, but 
without holding down the CTRL key.)

Reference Manager displays messages, asking you to 
confirm the copy or move of each reference. You can click Yes 
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for each reference or Yes to All if you want all the selections 
to copy or move automatically.

NOTE: You can also copy reference(s) between databases using the 
Copy Between Databases command. From the Reference menu, 
choose Copy Between Databases.
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Chapter 4: Building a Reference Manager 
Database

In this section of the Guided Tour you will learn to:

� Search an Online Database from Reference Manager

� Import References from Online, CD-ROM, or Web-based 
Services

� Enter and Edit References

� Spell Check Selected Text or an Entire Reference

� Launch Web Pages or Files from a Reference

Searching an 
Online 
Database from 
Reference 
Manager

As you build your database, you may search a variety of sources. 
You can search an online database directly from Reference 
Manager, and access the ISI Web of Science, PubMed, or 
hundreds of Z39.50 sites (such as academic and public library 
catalogs, the Library of Congress, and more). The references you 
find using Reference Manager’s Internet Search are placed in a 
temporary database that you can save permanently. You can 
move individual references to an existing database using drag 
and drop (or copy between databases).

You may also search other commercial and bibliographic 
services. Bibliographic data sources are generally available in 
these forms: diskette, CD-ROM, online, and Web-based services. 
Data tapes can also be installed on a local institutional network 
for controlled access.

The exercises that follow show you how to search online 
databases from Reference Manager and import a text file 
previously downloaded from PubMed.

Exercise – 
Searching an 
Online 
Database

This exercise guides you through the basic steps of connecting to 
and searching a remote database. You must be at a computer 
with Internet access – with either a dial-up or direct network 
connection.

For this exercise, you will connect to PubMed, which is made 
available by the National Library of Medicine and provides 
access to bibliographic and full-text databases. PubMed is the 
online database we will search; National Library of Medicine is 
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the information provider. PubMed comprises the full Medline 
medical database, and the pre-Medline records.

To search PubMed:

1. From the Tools menu, choose Internet Search.

2. From the drop-down list on the Search toolbar, select 
PubMed. The Internet Search box is already checked.

3. Now, build your search expression.

For this exercise, let’s say you are interested in information 
about the success of corrective eye surgery, such as lasik.

� In the first box under the Field column, select All fields 
if it doesn’t automatically display, and press ENTER. The 
cursor moves to the Parameter column.

� In the Parameter box, type “lasik”.

4. To start the Internet search, click the Start Search toolbar 
button (the binoculars) or press F12.

NOTE: If you haven’t already established a connection, your dial-up 
configuration should automatically dial and connect. If the connection is 
not successfully established, Reference Manager alerts you with an 
error message and stops the search attempt.

As the search progresses, Reference Manager displays status 
messages. 
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In our example, over 1500 records were found. PubMed 
displays a dialog allowing you to select a range of references.

NOTE: PubMed is updated regularly, so you may find a different 
number of references than illustrated here.

If the result set seems too big, you can always refine the 
search to get closer to exactly those references you want.

One technique to narrow your search is to retrieve some of 
the references, then open individual references to see what 
keywords are typically used in the online database. Then, 
use one of those keywords in your next search strategy.

5. In this case, click Cancel to stop retrieval and return to the 
Search window.

6. We will refine this search by looking for references that 
mention both lasik and surgical flaps:

� Leave the first search line as entered. 

� In the Connector box of the second line, select AND from 
the list.

� In the Field column of the second line, select MeSH 
Major Topic and press Tab.

� In the Parameter column of the second line, type 
“surgical flaps”.
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7. Click Start Search. This time 158 references are found.

The number of references found with the same search can 
change daily as online libraries are updated. 

8. Click OK. These references appear on a Search 1 tab. 

Subsequent searches would appear on a Search 2 tab, then a 
Search 3 tab, etc.

Browse the results or click sort your column headings to 
organize the reference list quickly.

To save the retrieved references:

You can save the entire set of references to a permanent database 
using Save As from the File menu. When you use Save As, do not 
give the new database the name of an existing database in the 
same folder; the old database would be replaced by the new one.

Or, for this example, identify the references you want to keep so 
you can drag and drop them into a permanent database. 

1. Highlight two or three of the references. 

You can hold down the SHIFT key to select adjacent 
references, or hold down the CTRL key to select references 
that are not next to each other.

2. Holding the mouse button down, drag the references to the 
Test database tab.

3. Let go of the mouse button to drop them into the Test 
database.

4. When a Confirm Move Reference dialog appears, click Yes to 
All to move each of the highlighted references.

If you do not save the references, you will be asked whether to 
save the database when you close either the Search tab or the 
Reference Manager program.

NOTE: As you copy or move references between database tabs, it is 
likely that you will receive a message about duplicate reference IDs. 
Unless a reference is already linked to a Word or WordPerfect 
document, it is fine to re-assign reference IDs.
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To close the Search tab:

You can execute as many Internet searches as you wish, with 
each search retrieved to another Search tab (up to a total of 15 
database tabs). This can get confusing once you have many 
database tabs to scroll through! 

When you have saved the references you want from a temporary 
Search database, you can close the tab to discard the temporary 
database.

1. Click on the Search tab you want to close.

2. Right click on the reference list to display a shortcut menu.

3. Select Close Search Database.

4. On the Closing Temporary Database dialog, click Close to 
throw away the temporary Search database.

It is not necessary to close Search tabs. When you close the 
Reference Manager program, you will be asked whether to save 
the references from any open Search tabs. As the program closes, 
all Search tabs are removed.

A Note about 
the ISI Web of 
Science

The Web of Science provides seamless access to current and 
retrospective multidisciplinary information from approximately 
8,500 of the most prestigious, high impact journals in the world. 
Through ISI Links, the Web of Science also offers navigation to 
electronic full-text journal articles, genetic information, and 
chemical and patent databases.

If you have a paid subscription, searching the Web of Science is 
essentially the same as searching other remote databases. You 
may copy your search results directly to a Reference Manager 
database. If you do not currently have prepaid access, you can go 
to www.isinet.com to learn more about it.

Exercise – 
Importing 
References

Another way to build a database without typing references is to 
import references. For example, you might search a resource 
provided by your institution (for example, Web of Science, 
Current Contents, Ovid, etc.). The results or selected references 
are downloaded into a text file, in a structured format. Reference 
Manager has predesigned import filters that move these 
references into your database with a few simple steps.

Before importing records, you must first download the records 
from the database service. In this example, we will use a text file 
that was previously downloaded from ToxLine. You will find 
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samples for supported services in the Reference Manager 
11\Samples folder.

To import a text file of references into Reference Manager:

1. You should currently have two database tabs open: the Test 
database and the Sample database. (It is okay to also have 
one or more Search tabs open.)

2. From the File menu, choose Import Text File.

3. On this dialog, set these values:

� From the Database drop-down list, select the Test 
database.

� Next to the Filter drop-down list, click the Browse button 
[…]. Locate the Reference Manager 11\Import folder where 
you will find the import filters supplied with Reference 
Manager. Locate the TOXLINE.CAP file, highlight it, and 
click Open.

� Next to the Text File drop-down list, click the browse 
button […]. Locate the Reference Manager 11\Samples 
folder, where you will find sample download files. 
Locate the Toxline.TXT file, highlight it, and click Open.

� The Reference Range setting can remain All. You can set 
a range if you imported a partial file and would like to 
pick up where you left off (for example, 50 to 124).

� The Default Reprint Status area helps you keep track of 
articles you maintain in your physical collection. You can 
browse the drop-down list and select any of the three 
settings: In File, Not In File, and On Request. The On 
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Request option is useful to help you track the date of 
your reprint requests.

� You can use the Additional keywords box to add 
keywords globally to the entire set of imported 
references. 

For this exercise, place your cursor in the first empty 
space and type “ToxLink.” A dynamic list of keywords 
associated with the target database appears and follows 
your keystrokes. If the term “ToxLink” is on the list and 
highlighted, you can press ENTER. If this term is new to 
the database, press Tab.

You might also find it handy to add today’s numerical 
date to track when the reference entered the database.

You can use the buttons at the bottom – Font, Greek, and 
Symbol – to change characters in the terms you are 
assigning.

Your dialog box should now look like this:

4. Click Import to import your records. 

Once the import is complete, Reference Manager displays a 
message, telling you that the import was successful.

5. Click OK.

An import log dialog box appears to confirm the number of 
references imported, the number of duplicates detected, and 
other details about the import process. Click Close to return 
to the Reference List.

You will now see an additional tab at the bottom of the 
Reference List labeled Imported. This tab shows the newly 
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imported references visually separated from the Test 
database for easy editing. These records are already saved in 
the Test database; any edits made on the Imported tab are 
reflected in the Test database. If you delete a reference from 
the Imported tab, it is also deleted from the Test database.

To close the Imported tab:

When you are done working with the imported references on the 
Imported tab, you can close the tab to remove the temporary list.

1. Click on the Imported tab.

2. Right click on the reference list to display a shortcut menu.

3. Select Close Imported Reference List.

The temporary Imported reference list disappears, but the 
references are still in the Test database.

It is not necessary to close the Imported tab. When you close the 
Reference Manager program, the Imported tab is removed.

Exercise – 
Inserting a 
New Reference

You will save time using the previous search and import 
methods to build your database. However, there may also be 
references that require keyboard entry, such as theses, 
dissertations, and conference proceedings. In Reference 
Manager, you use the same steps to both enter and edit 
references.

The following fields in Reference Manager work differently than 
regular text fields: Authors, Keywords, and Periodical. These 
fields provide dynamic access to names, terms, and titles that 
already exist in a given database, and are managed in Term 
Manager, which is discussed later in this tour.

To enter a new reference:

1. Click the appropriate tab to access the Sample database.
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2. From the Reference menu, choose New.

3. Click in the Reference Type field at the top of the Reference 
Edit window. From the drop-down list that appears, select 
the Journal reference type.

NOTE: The Journal reference type is used for an article within a journal, 
while the Journal (Full) reference type is used to identify an entire 
journal, rather than an article.

By default, a Ref ID (Reference ID) is sequentially assigned 
as each reference is entered in a database.

4. In the Title field, type the following title, using the Font 
toolbar to add italics to the Latin name. Note that 
punctuation is not added to the title field; it is added later by 
the selected output style.

The behavior and feeding ecology of the 
Pacific coast bottlenose dolphin Tursiops 
truncatus

NOTE: Do not apply text styles to an entire field. If a bibliographic style 
requests italicized titles, the italics will be applied by the output style.

5. In the Authors field, type the first author’s last name, 
“Shell”. The dynamic pop-up browser appears and follows 
your keystrokes. Locate and highlight “Shell, E.D.” Press 
ENTER to insert this author’s name into the new reference.
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6. Add your own name as the second author using the format

Lastname,F.M.

The dynamic pop-up browser appears, but you likely will 
not see your name on the existing author list. If you press 
ENTER, the highlighted name will insert. Instead, type a 
semi-colon (;) to leave your name and move to the next entry 
point. Your name turns blue to identify it as a new name in 
the author list.

7. Use the icon next to the Pub Date field name to switch 
between displaying the Year Only or the Full Date. The year 
automatically defaults to the system date on your machine.

For this exercise, change the field to Year Only and enter 
2001 as the date of this article.

8. The Web/URLs, Link to PDF, Link to Full-text, Related 
Records, and Image(s) fields are used to store links to Web 
pages or to documents on your computer. 

For example, you can create a link to the full text article if it 
is publicly accessible on the World Wide Web. You could 
also enter a link to your own research paper on your hard 
drive by using the Link to command from the References 
menu. For this exercise, create a link to the ISI ResearchSoft 
Web site.

In the Web/URLs field, type “www.isiresearchsoft.com”. 
Click on another field to transform the text into a hot link. 
Then, click the URL to launch your Web browser and go 
directly to the ISI ResearchSoft Web site. 

Switch back to Reference Manager to continue entering the 
reference.

9. Use the Notes field to store your personal annotations or 
anything related to this reference. For now, you can either 
type a note or leave the field blank.

10. Keywords are useful for instantly retrieving a related group 
of references in your database. 

If you have the automatic setting on to scan titles, notes, and 
abstracts for existing keywords, you already have keywords 
in this new reference (you can change this setting by going to 
Tools>Options>Reference Edit).

If the automatic keyword scan is off, and the keyword field 
is empty, type the following keywords. Use the same steps as 
with the author names; type a few characters and the 
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dynamic pop-up browser appears. Remember to use a semi-
colon when inserting new terms.

dolphin

behavior

If the keyword field already has entries, verify that these two 
terms are present. If not, move your cursor to the end of the 
keywords field and insert them. 

11. Click in the Reprint field and select In File from the drop-
down list.

12. In the Journal Name field, start typing Marine, and then 
select the journal name Marine Mammal Science from the 
pop-up list.

13. Press TAB to move your cursor progressively through the 
next few fields, entering the following information.

Volume – 3
Issue – 2
Start Page – 125
End Page – 128

14. The Abstract field is a free text field, and has no practical 
length limit. For this exercise, type your own short abstract, 
or the following:

This is a detailed article about the food 
chains existing along the Pacific coast

The User Defined fields are available for you to customize 
and use as you wish. For this exercise, leave the rest of the 
fields blank. 
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Your new reference should look something like this:

15. To save the reference, choose Save from the File menu, and 
then close the reference window. Or, simply close the 
reference edit window, and save the reference when 
prompted. Either choice will return you to the reference list 
window.

When you want to edit an existing reference, you can do so in the 
top pane of the reference list window, or you can double-click 
the reference in the reference list to open a full edit window. Edit 
a reference following the same rules as when you entered a new 
reference.

Exercise – 
Spell 
Checking a 
Reference

Reference Manager includes a spell checker to help identify 
incorrect words in all fields except authors and periodicals. You 
can also spell check a specific selection by highlighting a word or 
phrase.
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To use the spell checker:

1. Activate the Sample database and highlight the reference by 
Anderson,L.

2. In the top pane, click in the Notes field of the highlighted 
reference and type:

This book is about a famos Greek legend.

We are asking you to misspell “famous,” so that you fix it 
with the spell checker.

3. Click in the field above the Note field, then, from the Tools 
menu, choose Spell Check.

4. The Spell Check dialog appears and the word “famos” is 
identified as Not in Dictionary. Under Suggestions, select 
“famous” and click Change. 

Reference Manager continues to spell check the reference. 
You can click Cancel to close the spell checker.

5. Click on another reference in the reference list, and 
Reference Manager will advise you that changes were made 
to the current reference. Click Yes to save changes.
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Chapter 5: Retrieving References in a 
Database

In this section of the Guided Tour, you will learn to:

� Create a Search Strategy and Perform a Search

� Save a Search Strategy

Exercise – 
Creating a 
Search 
Strategy

You can search your Reference Manager databases to locate 
specific references for editing or printing bibliographies. Once 
you have located specific records, you can mark, delete, edit as a 
group, or print the references. You can search every field in a 
reference or limit the search to specific fields. After you create a 
search strategy, it can be saved with a name and recalled for later 
use.

A search strategy is a description of the criteria you would like 
Reference Manager to use when finding references in one or 
multiple open databases.

A search strategy contains the following items:

� Field—Select a single field or groups of fields to search, such 
as Authors.

� Parameter—Enter the word or phrase you want Reference 
Manager to locate.

� Connector—Use one of the logical connectors (AND, OR, or 
NOT) when more than one search parameter is used. 

The Results column lists the number of references found.

To create and use a search strategy:

1. The Sample database should be open. From the References 
menu, choose Search References. 

The Search window appears, and you will notice the Internet 
Search box is cleared.

2. From the drop-down list on the toolbar, select Sample to 
search the Sample database. 

When you have multiple databases open, you can use this 
drop-down list to search across All Open Databases. If you 
do not see the All Open Databases option, you can review the 
online Help topic indexed under “Databases: sorting” for 
more details.
Chapter 5: Retrieving References in a Database 39



3. Click in the Field column and type “K” to add “Keywords” 
to the Field column.

4. Click in the Parameter column and type “dolphin”. A 
browser pops up, listing all of the keywords in the database. 
Once dolphin is highlighted, double-click on it. The term is 
entered into the parameter field. Add an asterisk to the term 
to search for variations of “dolphin” such as the plural 
“dolphins.”

5. Narrow the search to include references related to behavior. 
Click the AND connector toolbar button. Type “behavior” 
and when the term when is highlighted, double click it to 
insert it.

6. Press TAB to move your cursor to the second line in the 
Connector column and type A (for AND).

7. In the Field column, type Y (for year).

8. In the Parameter column, type 1995-1996, and close the 
browser list. 

9. Click the Start Search toolbar button (the binoculars) or press 
F12 to begin the search.

Your search strategy, with results, should look like this:

The Results column displays the number of references that 
satisfy each level of the retrieval. In our example, the first 
line shows how many references contain both “dolphin*” 
and “behavior” in the Keywords field. The second line shows 
how many references meet the criteria of the first line plus 
contain dates from 1995 to 1996. 

10. To view results, click the appropriate Results button on any 
line.

A Retrieved tab appears, with the search results listed. 

Similar to the Imported tab, the Retrieved tab is a visual 
representation of references that are stored in the open 
databases— it is not a database itself.
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Each time you display new search results, the Retrieved tab is 
updated with the new list of matching references.

Exercise – 
Saving a 
Search 
Strategy

It can be useful to save search strategies that you use frequently. 
This exercise will teach you how to save the Search Strategy 
created in the steps above.

To save a search strategy:

1. To open the Search window, from the References menu, select 
Search References. The search you just created should remain 
intact.

2. Click the Strategy Files tool button, located to the right of the 
Start Search toolbar button. The Search Strategy dialog 
appears.

3. Click Save and give the Search Strategy a name, for example, 
“Dolphin.” 

4. Click OK to save your strategy. 

5. For this exercise, click Strategy Files again on the toolbar to 
confirm your search is saved for future use. 

(Later, you can return to this dialog, highlight one of your 
saved strategies, and select Load.)

6. Click Close to return to the Search window.

7. Click one of the Results buttons again to return to the 
Reference List window.

To close the Retrieved tab:

If you want to close the Retrieved tab, do it the same way you 
closed the Imported tab.

1. Click on the Retrieved tab to activate it.

2. Right click on the reference list to display a shortcut menu.

3. Select Close Retrieved Reference List.
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The temporary reference list of search results disappears, but the 
references are still in the Sample database.

It is not necessary to close the Retrieved tab. When you close the 
Reference Manager program, the Retrieved tab is removed.
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Chapter 6: Managing Reference Manager 
Term Lists

In this section of the Guided Tour you will learn to:

� Globally Edit Term Lists

� Create Synonyms

� Copy a Periodical List

� Retrieve References using Term Lists

You may remember the pop-up browser from previous exercises, 
and wonder how to remove unused terms, or perhaps merge 
terms that are synonyms with varied spelling (variations of 
words such as singular versus plural, or American English 
versus British English). Reference Manager provides Term 
Manager to quickly modify, combine, populate, and even 
retrieve references using your term lists of keywords, 
periodicals, and authors.

The exercises that follow show you how to perform a global 
replace or delete, combine or add terms to create synonyms, 
populate your periodical list with full and abbreviated journal 
names, and use Quick Retrieval to locate references.

Exercise – 
Globally 
Editing Term 
Lists

You can use the Global edit feature to correct misspelled terms 
or delete terms in Authors, Periodical, and Keywords fields 
throughout your database. This is especially helpful if you have 
a misspelled Author’s name, Periodical title, or Keyword. 

NOTE: You must open your database with Read-Write Exclusive 
access rights before you can use the Term Manager edit options. This 
requirement ensures you are the only one accessing the database 
during this process.

To globally edit a term list:

1. Activate the Sample database tab.

2. To open the Term Manager window, go to the Tools menu, 
choose the Term Manager submenu and then Activate. 
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The Keywords tab is typically active. Double-check that you 
are working on the Sample database; it appears in the drop-
down list on the toolbar.

3. Click the Authors tab and highlight the first author’s name 
that appears in all caps, ANTHONY,K.

Only certain journals require uppercased author names, so it 
is best to store the names in mixed case and let Output Styles 
apply capitalization or uppercasing when formatting a final 
document.

4. From the Tools>Term Manager menu, choose Global Edit.

The Source text box contains “ANTHONY,K.”

5. Type “Anthony,K.” in the Destination text box. 

The browser list appears and can be closed with the close 
button (x) in the top right corner.

6. Click Replace.

NOTE: You can delete a term on the same Global Edit dialog box by 
using the Delete button.

7. Click OK to confirm the change.
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8. Click Close to close the Global Edit dialog.

The Authors list now lists “Anthony,K.” rather than 
“ANTHONY,K.”

Exercise – 
Creating 
Synonyms

To create synonyms:

1. Ensure that the Term Manager window is active. If it is not, 
from the Tools menu choose Term Manager and then Activate. 

2. Click the Keywords tab.

3. Locate the term, “east-coast,” by starting to type the word. 
The highlight follows your keystrokes to help you find the 
term. 

Notice that there are two versions on the Keywords list: 
“east-coast” and “east coast”. Minor differences such as this 
are introduced into your database as you import data from 
various data sources. It can be difficult to maintain a clean 
list. Reference Manager gives you the opportunity to 
combine these terms for retrieval purposes.

4. Highlight both terms using the CTRL key. Then, from the 
Tools>Term Manager menu, choose Combine Terms. When the 
edits are complete, each term includes the other as a 
synonym. Now you can search on one of the synonym terms 
to locate references with either term.

Exercise – 
Copying a 
Periodical List

The Periodicals list works differently than the Keywords and 
Authors lists. Each periodical entry (including journals, 
magazines, and newspapers) can include up to four synonyms. 

The synonym list is preset to store the full journal name and up 
to three abbreviations. This synonym table is essential when you 
are submitting to a variety of publications with different 
formatting requirements. The selected Reference Manager 
Output Style determines which form of the periodical name is 
used.

Building a list of periodical names can take quite some time if 
you enter them manually. Reference Manager provides 
extensive periodical lists for three disciplines: Chemistry, the 
Humanities, and Medicine. You can also copy a periodical list 
from another database. Copying one of these periodical lists 
automatically populates your database with both the full and 
abbreviated periodical name. 
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To copy a periodical list:

1. Ensure that the Term Manager window is active. If it is not, 
from the Tools menu choose Term Manager and then Activate. 

2. Click on the Periodicals tab.

3. From the Tools>Term Manager menu, choose Copy Periodicals. 
The Copy Periodical dialog box appears.

4. Use the drop-down list in the Copy From field to select the 
Medical list.

The Select Database line becomes inactive.

5. Click OK.

This is a large list, so it may take some time to copy it all into 
your database. 

Once the copy process is complete, you can highlight a periodical 
name to view its full and abbreviated names, which are ready to 
use in your formatted bibliographies.

Exercise – 
Retrieving 
References 
using Term 
Lists

Term lists allow you to very quickly find references by keyword, 
periodical name, or author name. These fields are indexed for 
fast retrieval.

To retrieve references with term lists:

1. Ensure that the Term Manager window is active. If it is not, 
from the Tools menu choose Term Manager and then Activate. 

2. Click on the Keywords tab.

3. Scroll down the Keywords list to locate “animal behavior” 
and “animal communication.” Use the CTRL key to highlight 
both of these terms.

4. From the Tools>Term Manager menu, choose Quick Retrieval 
(or use the binoculars toolbar button) to initiate the search.

5. When the quick retrieval connector dialog appears, select OR 
and click OK.

You are returned to the reference list window with a new 
Retrieved tab and the results of your quick retrieval.
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Chapter 7: Citing References in a Document

In this section of the Guided Tour you will learn to:

� Open a Word Processing Document and View the Reference 
Manager Commands

� Cite Reference Manager References in your Manuscript

� Generate a Reference List

Reference Manager 11 installs menu items and a toolbar in 
Microsoft Word for Windows 2000, XP, or 2003 and WordPerfect 
for Windows 9 (2000), 10 (2002), or 11 (2003). These integrated 
tools provide you with the ability to search your database(s) and 
create instant bibliographies without leaving your word 
processor. 

The exercises that follow show you how to activate the Reference 
Manager toolbar, search for citations and insert citation place 
holders in your document, scan your document for identifying 
text, and create a manuscript with appropriately formatted in-
text citations and a reference list.

Exercise – 
Opening a 
Word 
Processing 
Document

To open a document and activate the Reference Manager 
toolbar:

1. With Reference Manager active, start Microsoft Word or 
WordPerfect.

2. Open a New Document.

3. Look at the Tools menu in your word processor. 

You should find a Reference Manager 11 submenu, with a 
right arrow and more selections. Each of the items on the 
Tools >Reference Manager 11 menu has a corresponding 
button on a Reference Manager toolbar. 

4. If the Reference Manager toolbar is not already visible, you 
can activate it.

Go to the View menu, select Toolbars and then Reference 
Manager 11. A toolbar should now appear on the screen. 
Place your cursor on any button for a few seconds and a tool 
tip will appear that describes the selected tool. You can use 
this toolbar for the following exercises. 

As you write a manuscript, you will want to cite specific 
references. Once these citations are inserted into your 
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manuscript, you can reformat the in-text citations and reference 
list as many times as you want and in any style you want.

To begin citing references:

� If you are using Microsoft Word, continue with the next 
exercise. 

� If you are using WordPerfect, jump to the following section, 
titled “Exercise—Inserting and Formatting Citations 
(WordPerfect 9-11).”

Exercise – 
Inserting and 
Formatting 
Citations 
(Word 2000, 
XP, or 2003)

You can search for Reference Manager references and insert 
them without ever leaving Microsoft Word. Citations can be 
inserted in an existing manuscript or as you write. As you work, 
Instant Formatting updates a reference list at the end of the 
document.

To insert citations in Microsoft Word:

1. Open the Reference Manager database(s) that contain the 
references you wish to cite—in this case, the Sample 
database. Then, open a Word document.

If you have been following the Guided Tour, and followed 
the previous exercise, you are ready. The Sample database is 
open, and you are in a new Word document.

2. Type the following: 

Bottlenose dolphins respond to boat traffic in 
various ways.

Now you are ready to insert a citation.

3. From the Tools menu, select Reference Manager 11 and then 
Insert Citation to display the Reference Manager Insert 
Citations dialog.
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4. In the Search for text box, type “dolphin”. Then click Perform 
Search.

The matching references are listed. Notice the number in the 
bottom right corner, which indicates the total number of 
references in the list. You should find over 100 references, 
which means you need more detailed search criteria to find 
the reference you want.

NOTE: Reference Manager will search the Authors, Date, Keywords, 
Titles, and RefID fields to locate references for you to cite. Separate 
each item with a space or a comma. Surround phrases with quotation 
marks.

5. Narrow the list by adding another term to the Search for box. 

This time, add the year 1996, so that the search item is 
“dolphin 1996”. Click Perform Search again. Now you have 
less than 20 references to review.

6. Select two or more references to cite in your document, using 
SHIFT-CLICK to select a series of references or CTRL-CLICK to 
select a random group, and then click Insert. 

Because Instant Formatting is turned on by default, the 
citation should format according to the current output style, 
and a reference list should appear at the end of the 
document.
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If Instant Formatting is not enabled, you will see 
placeholders that look something like this:

{Connor 1996 6/id;Cunningham, 1996 122/id}

This unformatted citation contains two references, and 
shows the first author’s last name, the year, and the reference 
ID number from Reference Manager.

7. Start a new paragraph, and type: 

The wild dolphin feeding program causes 
concern among experts.

8. Switch to the full Reference Manager application. You can do 
this by clicking the RM icon on the left side of the toolbar. 
Then, in the Sample database, mark one or two references by 
checking the box in the left column of the reference list.

9. Switch back to the Microsoft Word document. With your 
cursor placed after the new sentence, go to the Tools menu 
and select Reference Manager 11, then Insert Marked 
Reference(s). The new citation appears in the document.

You can continue adding citations as you write the paper, using 
both the Insert Citations command and the Insert Marked 
References command.

To format the citations and bibliography in various styles:

Instant Formatting works as you cite references. Reference 
Manager uses the currently selected style to format citations and 
update the bibliography. By default, Instant Formatting is 
enabled.

However, to change the style or layout of references, you must 
use the Generate Bibliography command. This formats your 
paper whether Instant Formatting is enabled or not. You can 
reformat as many times as you want, after adding more citations 
or to change the style or layout settings.

NOTE: Each time you use the Generate Bibliography command and 
select a different output style, that style becomes the default style for 
instant formatting.
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1. From the Tools menu in Microsoft Word, select Reference 
Manager 11 and then Generate Bibliography.

2. In the Output Style section near the top, click the drop-down 
list to select the output style titled American Psychological 
Association 5th ed. 

If no output styles are listed, click the browse button [...] and 
select American Psychological Association 5th ed from the 
Reference Manager 11\Styles folder.

3. When you select an output style, the settings on this tab are 
updated from the style. You can change options on this 
screen to override the settings in the output style. 

You may want to type a different Bibliography Title to print 
before your reference list, or select a different Bibliography 
order, or modify the line spacing.

4. Click OK.

The citations in your manuscript are automatically 
converted to the in-text citation format for the American 
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Psychological Association (APA), and the reference list is 
formatted in the APA style.

You can go through the steps again to select a different output 
style. This is the same paper formatted in the numbered Nature 
style.
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Exercise – 
Inserting and 
Formatting 
Citations 
(WordPerfect 
9-11)

To insert citations in WordPerfect:

1. Open the Reference Manager database(s) that contain the 
references you wish to cite—in this case, the Sample 
database. Then, open a WordPerfect document.

If you have been following the Guided Tour, you are ready. 
The Sample database is open, and you are in a new 
WordPerfect document.

2. Type the following: 

Bottlenose dolphins respond to boat traffic in 
various ways.

Now you are ready to insert a citation.

3. Select the first button on the Reference Manager toolbar or, 
from the Tools menu, choose Reference Manager 11 and then 
Insert Citation.

4. In the Identifying Text field, type “dolphin”. In the Look In 
area drop-down list, select the Sample database.

NOTE: Reference Manager will search the Authors, Date, Keywords, 
Titles, and RefID fields to locate references for you to cite. Separate 
each item with a space or a comma. Surround phrases with quotation 
marks.

5. Click Insert. 
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Reference Manager searches the database and returns a 
selection list if there is more than one item that meets the 
search criteria.

The matching references are listed. Notice the number in the 
bottom right corner, which indicates the total number of 
references in the list. You should find over 100 references, 
which means you need more detailed search criteria to find 
the reference you want.

6. Narrow the list by adding another term to the Search for box. 

This time, add the year 1996, so that the search item is 
“dolphin 1996”. Click the magnifying glass to restart the 
search with the new parameter. Now you have less than 20 
references to review.

7. Select two or more references to cite in your document, using 
SHIFT-CLICK to select a series of references or CTRL-CLICK to 
select a random group, and then click Insert. 

The placeholders can be author-date- ID or ID number and 
will look like this once inserted in your document:

{Ross & Wilson 1996 8 /id}{Horton 1996 66 /id}

8. Start a new paragraph, and type: 

The wild dolphin feeding program causes 
concern among experts.

9. Switch to the full Reference Manager application and mark 
one or more records by checking the box in the left column 
of the reference list.
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10. Switch back to the word processing document. With your 
cursor placed after the new sentence, go to the Tools menu, 
select Reference Manager 11, and then Insert Marked References. 
The new citation appears in your document.

To format the citations and bibliography in various styles:

When Reference Manager placeholders are inserted, they are 
linked to references in a Reference Manager database. You are 
ready to format the citations and generate a bibliography. The 
format is determined by the chosen Output Style and can include 
text (such as the author name and year) or numeric citations.

1. From the Tools menu, select Reference Manager 11 and then 
Generate Bibliography.

2. In the Output Style area, click the browse button [...] and 
select American Psychological Association 5th ed from the 
Reference Manager 11\Styles folder. 

3. When you select an output style, the settings on this tab are 
updated from the style. You can change options on this 
screen to override the settings in the output style. 

You may want to type a different Reference List Title to print 
before your reference list, or select a different Reference List 
order, or modify the line spacing.

4. Click OK.

The citations in your manuscript are automatically 
converted to the in-text citation format for the American 
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Psychological Association (APA), and the reference list is 
formatted in the APA style.

5. Select the Generate Bibliography tool button or menu option 
again, set the Output Style to Journal of Clinical 
Investigation, and click OK to view a completely different 
style with the same document.
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Chapter 8: Printing Bibliographies from 
Reference Manager

In this section of the Guided Tour you will learn to:

� Print a Bibliography directly from Reference Manager

� Print a Bibliography grouped by Subject

Exercise – 
Printing 
References

To print a list of references directly from Reference Manager:

1. In Reference Manager, activate the Sample database tab.

2. Select a print command in one of these ways (each one brings 
up the same Bibliography Setup dialog):

� From the File menu, select Print (CTRL+P).

� From the File menu, select Print Preview.

� From the Tools menu, select Bibliography and then 
Generate from Reference List (CTRL+L).

� Click the Print toolbar button (the icon that looks like a 
printer).

3. For this exercise, select these items on the General tab:

� Under References to include, select All references in list.

� Under Destination, select Print Preview.

� Under Output Style, select the style of your choice. 
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You can use the Browse button [...] to access the Styles folder 
and select from the complete list of available output styles.

� Under Optional Fields, clear all options.

4. Click OK to print a preview of the bibliography onscreen.

5. You can use the buttons along the top of the window to move 
between pages, and to Zoom In to enlarge the page.

When you are done viewing the preview, you can click the Print 
toolbar button to print to your printer if you wish. Click Close to 
close the preview and return to the Reference List window.

Exercise – 
Printing a 
Subject 
Bibliography

A subject bibliography is made up of a series of reference 
listings, each appearing under a distinct heading. Despite the 
name, a subject bibliography can be based on any Reference 
Manager field or combination of fields.

This exercise walks you through creating a subject bibliography 
based on keywords.

To print a subject bibliography:

1. In Reference Manager, activate the Sample database tab.

2. From the Tools menu, select Subject Bibliography to display a 
Subject Bibliography Setup dialog. 

3. For this exercise, select these items on the General tab:

� Under References to include, select All references in list.

� Under Output Style, select the style of your choice.
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� Under Optional Fields, clear all options.

4. Click on the Subject tab.

5. The Subject tab determines the layout and style of subject 
headings. 

� For this subject bibliography (versus a simple subject 
list), it is important that the Reference List selection be 
set to Subject Terms and Reference List.

� In the Suffix box, enter ^p^p to insert a blank line after 
each subject heading.

� At the bottom of the tab, under Styles, select the Bold 
style for Subject Terms.

You can leave the other settings in their current state.
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6. Click OK to save changes to the Subject Bibliography Setup 
tabs and display a list of the Reference Manager fields by 
default field name.

7. For this exercise, terms from the Keywords field will serve as 
subject headings. Highlight the Keywords field and click OK 
to display a list of all keywords found in the references.

8. Click Select All to quickly select all terms in the list. You can 
then click on individual terms to deselect them.
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9. Click OK to format the subject bibliography on the screen. 

NOTE: Subject headings print as they appear in your records. When 
you see variations in capitalization and uppercasing, it becomes clear 
that standardizing data entry and keywords is important.

10. You can try customizing your subject bibliography.

� If you want to modify the term selections you just set, to 
either add or remove keywords as headings, click the 
Terms button. 

� If you want to modify options that affect the layout and 
style of subject headings, click the Layout button.

11. When you are done viewing the subject bibliography, click 
Close to return to the Reference List window.
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Chapter 9: Publishing a Database with 
Web Publisher

In this section of the Guided Tour you will learn to:

� Add a Database for Publishing

� Enable Web Publisher

� View the Published Database with a Web Browser

With Web Publisher, you can easily share research and 
bibliographic information with colleagues through a network or 
remote connection. Web Publisher includes features and a built-
in Web server to quickly publish up to fifteen Reference Manager 
databases to an intranet or the World Wide Web directly from 
your computer. Anyone with access to your Web Publisher site 
can search published databases, export references, generate 
bibliographies, and edit references when databases are 
published with Read/Write access. 

NOTE: In a work environment, consult with your IT department before 
enabling Web Publisher.

In this section, you will walk through adding a database and 
enabling Web Publisher locally. For information about making 
your databases accessible on the World Wide Web or on an 
intranet, please refer to the Web Publisher section in the full 
Reference Manager manual or the online Help file.

Important 
Points about 
Web Publisher

Listed below are some important points about Web Publisher 
and published databases. 

� Web Publisher is a web server, modified for use with 
Reference Manager 11 only, running on the computer where 
Reference Manager 11 is installed.

� When exposing any web site outside a controlled environment 
(either through an intranet or the Internet), there is an inherent 
security risk. In these situations, a firewall and/or other 
security precautions are strongly recommended for use with 
Reference Manager Web Publisher. Before enabling Web 
Publisher, consult your network administrator, your firewall or 
other security application’s documentation, or another network 
professional. 
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� The IP address of the computer with the Reference Manager 
11 installation and a port number are required to use Web 
Publisher.

� The computer running Reference Manager 11 and Web 
Publisher must be on for the Web Publisher web site to be 
available.

� The computer running Web Publisher must have persistent 
access to Internet or intranet via TCP/IP. 

� When Web Publisher is enabled, at least one instance of 
RM11.exe and at least two instances of Apache.exe will appear 
in the “Processes” tab of Windows Task Manager. This is 
normal, and is required in order to support web access to 
published databases.

� You can publish up to fifteen databases with Web Publisher.

� Databases can be published with Read-Only or Read-Write 
Access rights. 

� Each published database maintains its own unique databases 
definition.

� Opening published databases with Read-Write Exclusive 
access in Reference Manager 11 prevents access to the 
database from the Web Publisher web site.

Exercise – 
Adding a 
Database

To add a Reference Manager database to Web Publisher:

1. From the Tools menu in Reference Manager, select Web 
Publisher.

2. On the Databases tab, select the Sample database to publish 
by selecting it from the database dropdown list or by 
browsing to it with the Browse button. 

3. Click Add.
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4. Click Apply to apply the change.

For this exercise, leave the access permissions at the bottom of 
the dialog set to “Read-only access to all published databases.”

Exercise – 
Enabling Web 
Publisher

To enable the Web Publisher web server:

1. Click the Configure tab.

By default, your computer’s IP address should appear on the 
dialog.

2. In the Web Publisher status section, select “Enable Web 
Publisher” to enable the Web Publisher web server.
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3. Click Apply to apply the change. In a moment, the “Reference 
Manager Web Publisher” line will switch from “Disabled” to 
“Enabled.”

4. The “Link to Reference Manager published databases” URL 
provided on this dialog is your Web Publisher URL. This is 
the URL of your Web Publisher site and can be accessed 
directly with a web browser. 

Make a note of this URL for the next exercise.

5. Click OK to leave the dialog.

Exercise – 
Viewing the 
Published 
Database with 
your Browser

Web Publisher web sites are optimized for 600 x 800 screen 
resolution, and support:

� Microsoft® Internet Explorer 4.0 and higher

� Netscape® 4.0 and higher
� Mozilla 1.4 and higher

NOTE: Cookies and JavaScript must be enabled.
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To access and search your Web Publisher database:

1. Leaving Reference Manager open, and the Sample database 
open with Read-only access, start your Web browser.

2. Enter your Web Publisher URL.

NOTE: Allow a few minutes for the web site to load, since Web 
Publisher was just recently enabled.

While you could type a word or phrase in the Quick Search 
text box to search all indexed fields (Author, Ref ID, 
Periodical, and Keywords), for this exercise we will do an 
Advanced Search.

3. Click the Advanced Search link. 

The Advanced Search option provides the same search 
functionality as searching in Reference Manager.

4. Enter an Advanced Search as shown in the picture below, to 
search for “dolphin” in the Keywords field and ““zoo*” in all 
non-indexed text fields.
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5. Click Search to begin the search and list the matching 
references.

6. You can experiment with searching, viewing, and printing 
references. 

� To execute a Quick Search, enter a word or phrase in the 
text box and click Search.

� To execute another Advanced Search, click the Advanced 
Search link.
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� To view full reference information, click the View link to 
the right of each reference.

� To view a bibliography, either individually select the 
check box to the left of each reference you wish to 
include, or click Select All References, and then click 
Bibliography.

For more information about options for configuring and using 
Web Publisher, see the Web Publisher section in the Help file. Or, 
see “Chapter 18: Publishing Databases with Web Publisher” in 
the full Reference Manager 11 manual. The full manual is 
available as a PDF file in the Reference Manager 11 folder.

Exercise – 
Disabling Web 
Publisher

When you are done experimenting with Web Publisher, you may 
want to disable it.

To disable the Web Publisher web server:

1. If you have not already done so, close the Web Publisher site 
in your browser.

2. From the Tools menu in Reference Manager, select Web 
Publisher.

3. Click the Configure tab.

4. In the Web Publisher status section, select “Disable Web 
Publisher” to turn off the Web Publisher web server.

5. Click Apply to apply the change. In a moment, the “Reference 
Manager Web Publisher” line will switch from “Enabled” to 
“Disabled.”

6. Click OK to leave the dialog.
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Congratulations!

You have successfully completed this Guided Tour! Now you are 
ready to begin searching the Internet, creating your own 
personal reference collection, and building perfectly formatted 
bibliographies.
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